1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

d16y7 in 5th gen hatch 3k revlimiter wtf

Discussion in 'ECU's, Electronics, and Tuning' started by rnrmotorsports, Sep 28, 2008.

  1. rnrmotorsports

    rnrmotorsports New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Sep 28, 2008
    ok tonight i put a d16y7 into a 93 honda civic si hatchback, i used the following just so you guys know
    96 civic d16y7
    93 si intake manifold
    y7 distributor with 5th gen sdisty internals
    p28 5sp ecu

    car runs fantastic however it cuts out at 3k like im hitting rev limiter all plugs plugged in the right way.

    however there was one plug coming off the engine that didnt have a spot on the 5th gen si harness coming from the engine by the timing belt cover is this plug related to my problem if so how do i fix it if not what is my problem any help is appreciated
     
  2. ccsgsr1

    ccsgsr1 Banned

    Messages:
    58
    Likes Received:
    2
    Joined:
    Jul 20, 2008
    Location:
    POCONOS
    thats crank position sensor. you need that hooked up. Sounds like limp mode...
     
  3. rnrmotorsports

    rnrmotorsports New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Sep 28, 2008
    so how do i wire that into a 5th gen running a p28 and a 5th gen harness
     
  4. sscivicsi

    sscivicsi New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Nov 9, 2008
    running the p28 you do not need to hook this up. sounds like you have one wire off in the dizzy plug.
     
Verification:
Draft saved Draft deleted

Share This Page