1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ef hatch ls swap

Discussion in 'Civic and CRX - EF' started by tegman88, Apr 30, 2008.

  1. tegman88

    tegman88 New Member

    Messages:
    79
    Likes Received:
    1
    Joined:
    Apr 30, 2008
    Location:
    spartanburg sc
    alright i just put a ls in a dx ef hatch the problem is that when i turn the ignition on the fuel pump want turn on
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    check your main relay
     
  3. efhondakid

    efhondakid My name is Byron. VIP

    Messages:
    7,034
    Likes Received:
    202
    Joined:
    Mar 2, 2007
    Location:
    Akron-Canton, Ohio
    Check all your grounds.
     
  4. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    +1

    does anything else comeon?
     
  5. tegman88

    tegman88 New Member

    Messages:
    79
    Likes Received:
    1
    Joined:
    Apr 30, 2008
    Location:
    spartanburg sc
    the main relay clicks on and off right but when i first turned the key on it acted like it was hung open and it just clicked constantley and then it was fine. when i took the main fuel line off from the filter to see if i could get any gas to come out and i kept turning the switch on and off and it finally shot a little squirt of gas out i put a si dash harness in it is there a ground on it that could be causing it
     
  6. efhondakid

    efhondakid My name is Byron. VIP

    Messages:
    7,034
    Likes Received:
    202
    Joined:
    Mar 2, 2007
    Location:
    Akron-Canton, Ohio
    Do you have dash lights (CEL, battery, oil, ect) when you turn the key on? And do you have any codes? And check your grounds, the one on the thermostat housing is the ECU ground, without it hooked up the ECU wont come on.
     
  7. tegman88

    tegman88 New Member

    Messages:
    79
    Likes Received:
    1
    Joined:
    Apr 30, 2008
    Location:
    spartanburg sc
    i dont even have the dash back in but i dont know if i put that ground on the thermostat housing either ill try that tomorow when i go back to work do i have to put the dash back in to get it to run this is the first time i ever put a dash harness in one and all im tryin to do right now is get it to run just to see if it will because i dont know the history of the motor and the guy got for real cheap price
     
  8. tegman88

    tegman88 New Member

    Messages:
    79
    Likes Received:
    1
    Joined:
    Apr 30, 2008
    Location:
    spartanburg sc
    i put the ground on today and the fuel pump kicked on but now the distributor isnt firing the ecu is on now also what could be my problem with the distributor
     
Verification:
Draft saved Draft deleted

Share This Page