1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

vtec quit working on my b18c type r need help!!!

Discussion in 'Civic and CRX - EF' started by vpower, Nov 17, 2009.

  1. vpower

    vpower New Member

    Messages:
    342
    Likes Received:
    1
    Joined:
    Nov 7, 2009
    Location:
    L.A.
    My 91 si hatch runs strong still...oil level is good just did oil change today...already checked speed cable and its plugged in...made sure all belts were not loose...what else can it be???need help also with which oil filter I need left the old one on the motor cuz I had purchased the wrong one...haven't drove the car but maybe 2 miles to test the vtec after the oil change but still no luck...need to replace the oil filter...have a jdm b18c with itr head...plz help...
     
  2. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,453
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
  3. vpower

    vpower New Member

    Messages:
    342
    Likes Received:
    1
    Joined:
    Nov 7, 2009
    Location:
    L.A.
    Alrite do u know which oil filter I need
     
  4. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,453
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
    94-2000 integra gsr
     
  5. vpower

    vpower New Member

    Messages:
    342
    Likes Received:
    1
    Joined:
    Nov 7, 2009
    Location:
    L.A.
    Kewl thanx...can my vtec problem be cuz my wiring from the ecu isn't clean???should I take it to a shop and have the car re-wired???
     
  6. vpower

    vpower New Member

    Messages:
    342
    Likes Received:
    1
    Joined:
    Nov 7, 2009
    Location:
    L.A.
    Can it be possible that it can be one of my sensors...I got the car like 2 weeks ago and the check engine light was on but I have no clue what's wrong
     
  7. hondahurley

    hondahurley New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Nov 20, 2009
    Location:
    cork city
    has the car low vtec power r is there no vtec at all it can only be something small i may have the ans but need 2 know first
     
  8. pooksy64

    pooksy64 RidetilldeathdousparT

    Messages:
    148
    Likes Received:
    1
    Joined:
    Jul 18, 2008
    Location:
    HOUSTON tX
    in order for the ECU to engauge VTEC the following has to ready ECT has to be @ operating temp. no knock frm knock sensor. oil level has to be perfect. oil psi sensor must read a certain psi frm 3000rpm and up. TPS must be @ 75-100%(4.2-5.0V) throttle basically WOT
     
  9. shdw b18c

    shdw b18c New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    Nov 21, 2009
    Location:
    CALI
    U got i wired wrong thats the problem. Also if your using a usdm ecu it will ask u for vtec oil pressure sensor and jdms dont hAve one so u need to bypass it
     
  10. adriane909

    adriane909 New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jul 23, 2011
    Hi I have a 90 Acura Integra with a b18c1. My vtec was working fine it. Now I am having issues, it wont engage. I have checked my oil and the oil is fine. What should I look into next?
     
  11. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,416
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    One should ALWAYS check the code off the check engine light........please.
     
  12. mrjdm

    mrjdm New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Aug 3, 2011
    brother i just signed up to this forum yer i love my honda's the problems with your car 2 things either one your V=-tec soilinoide is stuffed need a new one or two wires detached.
     
Verification:
Draft saved Draft deleted

Share This Page