Need Help With My Teins.

We may earn a small commission from affiliate links and paid advertisements. Terms

eyesonlybob

Senior Member
ok, heres the intro:

i have a 95 civic dx coupe and i have the tein type ss coilovers. i got everything installed and i am using the oem upper mounts which i bought new. after installing them, i lowered the car off of the jack, and this is what i saw:

s3e346eb0686d5.jpg


the piston rod pushed the collar and upper rubber piece through the upper mount. which makes complete sence looking at this picture:

s3e346ed274a24.jpg


the piston rod of the teins is pushing on the collar and rubber piece in the area of the lime green circle, making it push through the upper mount.

now looking at this picture from my helms:

s3e2332b6c2c24.jpg


it appears that i need the dust cover plate maybe, or something that will push on the upper mount in the teal colored area of the mount. am i right? or did i not assemble the mounts right? i dont see anything that would make it not go through the upper mount? help please. i have more pictures if needed.
 

eyesonlybob

Senior Member
no its not the bump stop plate, its the dust cover plate. i needed this:

s3e34a419d3d93.jpg


problem solved, guess i didnt need to post topic since if figured it out myself.
 

asmallsol

Super Moderator
Originally posted by eyesonlybob@Jan 26 2003, 10:21 PM
problem solved, guess i didnt need to post topic since if figured it out myself.

no not really, because if you have a question on something and get it solved you may have just helped someone else out that is having the same problem
 
Top