1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b20b swap 91 teg

Discussion in 'Integra' started by build_drive_smile, Apr 1, 2016.

  1. build_drive_smile

    build_drive_smile New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 1, 2016
    I have a 91 L's I pulled the b18a1 and went with b20b low comp from 96-97 CRV won't stay running and puffs white smoke from intake. I know there are a lot of forums on b20 swaps but my question is if I use the b20 distributor wired in it will start and run for about one minute while wanting to die out the whole time before it finally does. If I use stock Ls dizzy it gets spark but won't crank at all. Any suggestions???
     
  2. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I know that the typical way of swapping into your chassis is to use the entire B18A1 intake manifold/throttle body (sensors, fuel rail, injectors, etc.), distributor, engine harness and ECU. Essentially, only swap out the head and bottom end. I would use all sensors off the B18A1 block too.

    If you did it that way and there are issues, I would start diagnosing by checking CEL's and a leak down test.

    With OBD being different, too many issues can arise doing it any other way....but other ways are possible.
     
  3. build_drive_smile

    build_drive_smile New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 1, 2016
    Yeah i used all my b18a1 parts. The weird thing is if I try to use my stock distributor (which worked on my old motor) it won't even start but is getting spark. But when I wire in the stock b20 it will run but kicks a crank sensor code and runs like shit.
     
    Last edited by a moderator: Apr 3, 2016
  4. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Something isn't right. If you swapped over the entire B18A1 stuff....it's a rap.

    All the wiring for injectors and such switched over?

    I've read of people hooking up the dizzy 180° off but never tried it myself.

    All B18A1 installed.....any codes?
     
  5. dilbeckskate

    dilbeckskate infamous

    Messages:
    3,106
    Likes Received:
    195
    Joined:
    Aug 20, 2010
    Location:
    Kennesaw Ga
    Literally you use the b18 dist and intake and the car never knows the difference, install error
     
  6. build_drive_smile

    build_drive_smile New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 1, 2016
    Crank sensor code when I use the b20 dizzy but no codes when it won't crank with the b18 dizzy. The injectors are good. Used b18a1 intake fuel rail and injectors. Thanks for the response btw this shit has me puzzled.
     
  7. dilbeckskate

    dilbeckskate infamous

    Messages:
    3,106
    Likes Received:
    195
    Joined:
    Aug 20, 2010
    Location:
    Kennesaw Ga
    Check thermostat ground
     
  8. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    How are you plugging in the OBD2 dizzy and the OBD0 dizzy? Conversion plug?
     
    dilbeckskate likes this.
  9. build_drive_smile

    build_drive_smile New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 1, 2016
    NOTE="CAFROG, post: 1838968, member: 55654"]How are you plugging in the OBD2 dizzy and the OBD0 dizzy? Conversion plug?[/QUOTE]
    No i wired them in according to the diagrams for each distributor. I checked the thermo ground its connected looks a little corroded but its solid.
     
  10. dilbeckskate

    dilbeckskate infamous

    Messages:
    3,106
    Likes Received:
    195
    Joined:
    Aug 20, 2010
    Location:
    Kennesaw Ga
    The variables grow on each of your post
     
  11. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I'm worried it is in the wire job at the dizzy. Triple check you have it back to basics....OBD0 wiring ONLY. The entire engine harness should be ALL OBD0
     
  12. build_drive_smile

    build_drive_smile New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Apr 1, 2016
    I agree but with the stock b18a dizzy (which ran on the motor I pulled) won't run. It tries to start the first turn of the key but then just spins over like nothing is happening. Then if I turn the key off for a few seconds it does the same thing. Tries on first crank then just spins over after that. I know when it was running but trying to die out it had the b20 dizzy and I know it was wired wrong with the cps wire and the cyps wire switched. That's the only way it ran at all. I'm sure this is install error of some kind I just can't pinpoint where. But I do have stock b18 dizzy in now and will not be messing with b20 dizzy any more. So now it won't crank so I am starting from there. Thank you for the help btw.
     
Verification:
Draft saved Draft deleted

Share This Page