B16a2 Swap Problem

  • Thread starter civic_SI_hatch
  • Start date
  • Replies 14
  • Views 2K

We may earn a small commission from affiliate links and paid advertisements. Terms

C

civic_SI_hatch

Guest
i just swaped in a 99 civic si motor into a 92 civic si hatch... i used my old harness and the ecu of the 92 motor... i cut the wire from the fuel injectors and the distributor and also the aternator... it ran good at first... but now it seems to lagg... what seems to be the problem? could it be the ecu ? or can it be the wires that i cut and re-wire..? when vtec kicks in the car seems to lagg even more... i also lost to a stock dx... help....!
 

B16

Super Moderator
VIP
lol, pull the codes first and tell us what they are, that will help a lot :)
 

ventolin5

Senior Member
I am 99% positive that i am going to do the same swap into my 93 si hb.

So, how easy was the swap anyways? And please post how you like the
engine in your hb (after u get it running right).
 
C

civic_SI_hatch

Guest
at first it ran fast... pulls hard... 14.8 with just an injen cold air intake... after that it dont run right anymore ... its easy to install in the motor ... you might need the back mount for it... after that everything fit right in...
 
C

civic_SI_hatch

Guest
oh yea and the 99 si ecu wouldnt work not for me cause i used my old harness off the 92 si
 

mical0259

Junior Member
yo, what mounts did you use? also what distributor.im doin the same swap and dont know if i gotta buy all mounts or just some. also should i buy an obd-1 distributor or just chang the clips? im usin my 94 civic harness.

you shoulda got a different ecu or chipped the one you got.
 

xj0hnx

I wanna be sedated
VIP
Originally posted by mical0259@Feb 20 2003, 12:55 AM
yo, what mounts did you use? also what distributor.im doin the same swap and dont know if i gotta buy all mounts or just some. also should i buy an obd-1 distributor or just chang the clips? im usin my 94 civic harness.

you shoulda got a different ecu or chipped the one you got.

yO!!! Start your own thread,don't jack others.
 

MR. EG

Member
If you used your old single cam ecu you should get it rechipped. The fuel maps are not going to be the same. good luck


ps do you know how to check your codes.
 

Akirazian

Banned
ok i did a JDM B16a SIR II motor into my EG6. First of all use 92-95 Civic Si Engine Harness so cutting wires is not neccessary. Especially the O2 sensor problem. Damn shiet gave me a hard time. Throwing O2 sensor. Because on the stock civic engine harness only have one wire for the ECU but the B16a have 4 wires. So therefore use 92-95 Honda Civic EX or Si engine harness.

Also use Del Sol VTEC engine mounts, 94+ integra B series engine mounts, or the 99-00 Civic Si engine mounts. Whatever you do. DO NOT USE YOUR STOCK ENGINE MOUNTS!!!!!!! It will work but you will have a hard ass time later on. The axles will not be straight. And you might have problems with the axles later on. So be sure to use only B series engine mounts.

Ummm, you can used the SOHC VTEC ECU but it have to be rechipped to the B16a specification. It is way off. I recommend using the B16a ECU!!! Or 94+GSR ECU
 

nealo

Senior Member
Hi man. I wanna do the same swap. sorry if i interrupted your post and shit. How much did you pay for all your shit?
 

simonc

Member
We copmpletely the samw swap, B16a2 in a 1993 EG hatch.
Firstly find out what your CEL codes are.
The probs we had were the intake air temp sensor should be in the induction kit and not he inlet manifold on later B16a engines, make sure you've got this wired up ok. Make sure you're running a 4 wire o2 sensor, we used a Euro spec P30 ecu, if you're using a P28 get it chipped asap, as standard it will kill a B16a, especially at high revs.
voila
 
C

civic_SI_hatch

Guest
i'm getting a skunk2 chip... its for a d16 b16 and 94 gsr... will it work for the swap? or should i just go ahead and get a gsr ecu?
 
Top