H22a Swap Into Accord

We may earn a small commission from affiliate links and paid advertisements. Terms

I swaped the JDM H22a into my 95 Accord Ex. I was running rough but i solved that issue but now the Number 1 Cylinder wont fire. It has compression and is getting spark. I pulled out the injector and swaped it with another cylinder and still only the Number 1 cylinder doesnt fire. Any ideas what could cause this?
I checked the injector wiring and they all test the same voltage even the number 1 cylinder

i also checked the ignition resistor it it checked out ok

and it also gets fuel
if its getting fuel i dont think its the fuel rail, and if it IS clogged, hes got more problems than that, i vote wiring or something to to with the ecu, how did you check to see if it has fuel and spark?
im no mechanic but i was wondering if you checked your spark plug, for spark or did you do the old method of sticking something in the wire and let it arc of something? have you tried going back to how it was set before you adjusted it?
Tested Spark two ways.. I had spark but now i have nothing it wont spark at all on any cylinders..checked distributer it tested ok..Everything tests ok..Anyone know if the MAP sensor can cause an engine to stop firing??
well, if you're getting fuel and spark and your distributor is fine then that probably means your ecu is not working properly..... it's probably a glitch when it reaches cylinder one during the cycle when it's suppose to fire..... you're motor is receiving all the power or electricity it needs but the directions aren't being sent out from the ecu to fire the cylinder....
this is what my friend told me when i asked him about your situation and he's an electronics major so.....
hopefully this helps a little
Here's my vote.

ok, hold on... you're saying that cyl 1 doesn't fire, BUT it gets spark, fuel, and compression.... how can it NOT fire?

That sounds odd to me, I vote to check the sparkplug well for scrapes or sharp pieces of metal, I'm betting that your plug wire is "leaking" into the head, so it'll spark when you test it, but when it's in there, the spark doesn't go to the plug, but to the head through the penetrated insulation. Try replacing your wires.

I got money says you have a set of KEM or some other cheap wire from Pep Boys in there that's leaking, trust me, I've dealt with the same problem. Change out your wires and you should be golden, my friend. :)
Make sure to check for any leaks from the intake manifold to the head by spraying some soap and water around it. I had the same problem before with my accord.. If it bubbles then that'll indicate that coolant may be leaking between the intake manifold's gasket... Good luck