Matts96HB's EJ6 Build

We may earn a small commission from affiliate links and paid advertisements. Terms

Matts96HB

.
Moderator
VIP
Here's an update on the progress of my ek. Last night I tore into it and started on the LS swap. Got the motor all mounted up, and ready to go. Today is wiring and finishing up random little bits of stuff, then hopefully startup! Heres some pics.
4bgcs4k.jpg

The D16Y7 just about ready to come out.
2dr81h3.jpg

No more D!! :)
2pql34k.jpg

LS swap getting ready to go in with the Unorthodox Pulleys on
40e4hmr.jpg

Its in.

This swap has been fairly easy, it was pretty fun to do. I cleaned the engine bay with degreaser while the D was out and the LS was being prepped. My dad and I tackled this in about 10 hours, taking our time on everything. Future plans are most likely a HMT on the LS, and im going to tear down and rebuild the D, find a crx and make a nice daily driver. Thx for lookin.
 

Matts96HB

.
Moderator
VIP
Low boost, 8-10 psi.

I have a few questions..
I got an OBD2 motor, and im using my stock DX harness which im told should work because its OBD2. Problem is, some of the plugs either dont reach, or I cant seem to find the place for them. Mainly on the Alt. side of the motor. I ran the wiring harness exactly where it was before, under the IM and out onto the other side. The injector plugs all reach without problem, if anyone could provide me with some info that would be great, thx.

EDIT:
On second thought, Im not even 100% sure if the swap is obd2 or not. Im almost positive it is obd1 now, after seeing that the P75 i was given is an OBD1 ECU. Also, when I called up the people from JDMonline.com, I was told that I was being sent an OBD2 motor, but to buy the shift linkage and throttle cable from a 95 integra LS, how can these match up if I have an OBD2 motor??
 
Last edited:

BrutalB83

Brutal Moderator
Moderator
VIP
I dunno man, it looks like an OBD2 motor to me. I have a 97 Integra, and the valve cover looks exactly the same as yours, but I noticed that on some of the older B18Bs the valve cover is slightly different.

Anyways, good work on the swap.
 

Matts96HB

.
Moderator
VIP
Well, I know I have an OBD1 ecu. So, provided that JDMONLINE did give me the correct ECU for this motor, I have an OBD1 motor. Huge complaint of mine against JDMONLINE is that we asked for an OBD2 motor, he said we would get one. Such BS, now I have to get a jumper harness and start all over again.
 

killercannible

Senior Member
The pcv valve in the valve cover is a dead givaway, only obd2 motors have those. Also, as far as the wiring harness don't stress on missing plugs and stuff. Take your time and you will find their respective locations. There are a few under the intake manifold on the block that are hard to see. I did a b16 in my 97 ex, the ex harness is the same except it has vtec wired in already. I didn't have to cut and extend any wires at all. The only thing i had to do to get some wires to reach is removing some of the sheath around them. Also, make sure you don't swap up some of the plugs because honda used the same plugs for different sensors. For example the plug for the map sensor is the same as the plug for the evap canister(I think) if you mix these two up like i did it won't run.
 

dbone_vtec

HONDA 4 LIFE
MATT

YOUR DOING GREAT. TAKE THE TIME TO DO IT RIGHT

YOUR EK IS OBD2 SO YOU NEED AN OBD2 LS INTEGRA ECU TO RUN THAT

MOTOR CORRECTLY

THE SHIFT LINKAGE FROM A 94 AND UP INTEGRA WILL FIT

KEEP UP THE GOOD WORK

HOPE TO BUILD CARS WITH MY SON SOMEDAY:drinks_drunk:
 

Matts96HB

.
Moderator
VIP
Thanks for the help guys!
I think I may have been given a different ECU, because it seems to me that it is OBD1. I tried taking out my P2E and putting in the P75 but the plugs are different, I looked at some pics of the OBD1 ECU's, and it has the same plug pattern as those. I think that might be what is throwing me off. As for everything else, ill be posting up a ton of pics, I'll need some help lol. Still have to get the throttle linkage and fuel line, plus two bolts that hold the intermediate shaft in, they are collared (sp) and are very hard to find.

So I will need a P75 then, but the OBD2 ECU?

And I already have the shift linkage installed, tranny feels great. Its an SiR Tranny :)

Again, thanks for the help and encouragement!
 

Matts96HB

.
Moderator
VIP
Im at a loss here, plugs all over the place, but nowhere to put them on the motor!! Is there any wiring diagrams or anything that will help me out? I have everything on the distributor side of the motor hooked up except exhaust, but im really lost as to where everything else goes. I'll post pics in a few.
 

Matts96HB

.
Moderator
VIP
Alright, so heres what ive got so far.
These two plugs (underneath intake manifold right now)
[img=http://img391.imageshack.us/img391/5659/plugswtfkr1.th.jpg]
Not really sure where these go, if anyone could identify them or let me know where to put them.

Then these next few. Note that nothing is connected to the intake mani. and i know there should be something, so i think i know where one of them goes. If anyone can identify the others that would be great.
[img=http://img391.imageshack.us/img391/1605/plugswtf2ib4.th.jpg]
I really need some help here.
 

killercannible

Senior Member
The first two plugs you asked about don't go anywhere, look closely at them and you will see they aren't really plugs.
 

dbone_vtec

HONDA 4 LIFE
I remember you said you used the harness off the original motor

compare the intakes to figure it out for the three near ALT.
 

Matts96HB

.
Moderator
VIP
Yeah, so the only problem right now is that the plugs arent matching up. There is one that is causing a problem really. Theres one on the back of the intake manifold on the b18, that has a vaccum line running to it. Only problem is, its a square plug, and I dont have any of those on the old harness that arent being used already. I dont have that piece of the old harness to compare to either, becuse it was cut. Hopefully I can get it to work though. Bumped the starter tonight, just to make sure it was good, and it turned right over so thats good. Fuel stuff comes in tomorrow, along with the two collared bolts that were missing from the intermediate shaft.
 

Matts96HB

.
Moderator
VIP
The plug on the back of the intake manifold points down. Round plug, points down. It has two wires on the LS harness, but three wires on the D16 harness. What do I do here? Some sort of conversion I need to make? Any help is greatly appreciated.
 

Matts96HB

.
Moderator
VIP
Its from unorthodox racing. I got the full set from a buddy for $40. Im only using the crank and alt. pulley though :p
 

Matts96HB

.
Moderator
VIP
Got it started up, full 3" exhaust installed, vibrant performance muffler & resonator, metal core cat. all setup for boost.

Runs pretty quick with the SiR tranny, i like it. :) sounds mean too.
 
Top