2000 buell blast

We may earn a small commission from affiliate links and paid advertisements. Terms

my father said the same thing. but there are like 30 different cv40 aftermarket needles. i cant see why it had an aftermarket needle and no jets, with mods.

it was just easier to return it to zero and shim it lol i was trying to measure the graduations, i think they were .06 each. i needed .05 at max. i got .03 .
 
my father said the same thing. but there are like 30 different cv40 aftermarket needles. i cant see why it had an aftermarket needle and no jets, with mods.

it was just easier to return it to zero and shim it lol i was trying to measure the graduations, i think they were .06 each. i needed .05 at max. i got .03 .
There's more than 30... Lol.

It had an aftermarket needle because that's standard off-the-shelf parts for a cv40. I would have put it on the second clip and checked it. I bet it'd run slightly cooler. :p
 
that may make total sense for you, but most of the stock harley carbs dont have an adjustable needle.

im gonna start it before too long... after my 1pm call maybe.
 
Well we are good to go! I buttoned this sucker up. The tach works. No fuel leaks and the throttle tip in stumble is gone. After the first startup I let it sit a bit and t started right up. Before it would take some time to get going.


CD2F1A95-A9BC-46BC-9C16-8B6040A24ACF.jpeg

 
Forgot I needed to plug the emissions tube hole, lol used one of the spare trunk lid bumpers I had from the blue Kia. It was a perfect press fit after shaving it down a bit.

then I had to take it apart again since I forgot to put the air filter back in. The new airbox gasket makes it really hard to get the clips on and off !

F0D34AD6-A9A9-4698-9D71-6F6020E0ABF8.jpeg
 
Finally got my plates today. They came in the mail... Friday.

anyways I got the bike out and moving and it’s just not charging. The old regulator would show around 11.5-7 and stay in that range. I checked the stator and it would go up to about 55 or so vAC at 2k rpm. According to the manual the stator is good. I swapped the regulator and now it won’t go over 10.5 and I can watch it slowly drop as I ride. I ohmd all the fuses and cleaned them they are good. I’m going to look at the grounds next. And get the battery on a charger. I saw some things about the bike not being happy if it’s not over 12v.

I am going to order a stator... I have to remove the half the covers to get the oil back in anyways May as well take another 30 minites

otherwise it goes decent and idles a little low. 2500-3500 it vibrates like crazy! Otherwise smooths out.

and it’s really loud up over 4K. I’ll try to get a video tomorrow after I charge the battery.
96A64F52-CC80-4221-838C-44CEBA22B553.jpeg
 
I think the battery is junk...

tendered the battery it stayed 12-12.3 volts the entire ride, started up fine... got 14 miles out of it yesterday with plenty more to go but it was getting cold.

today im Hoping to adjust the mixture/idle since I’m comfortable with how the bike is going but it smells of gas abd there obvious gas banding on the airbox lol. I haven’t adjusted any of this yet. I should have ordered the eZ adjust knurls for when I had the carb out lol. Luckily I can turn the screws with a very short eyeglass screwdriver.




55516838-E0C3-4C45-9AE9-7093BA666CCF.jpeg
F75D1636-45F7-4320-B5BF-97B8524B8673.jpeg
 
Get something like this:

1620048041871.png


It's called the BikeMaster 18-JVE4306, Extra Reach Adjustment Screwdriver. Motion Pro and PitPosse make one, but they're probably out of stock since it's spring.
 
the knurls are 30 shipped just seems easier to fix the root problem then to buy another stupid tool for this bike, lol

oh cool its a ratcheting screwdriver, that is very neat!
 
the knurls are 30 shipped just seems easier to fix the root problem then to buy another stupid tool for this bike, lol

oh cool its a ratcheting screwdriver, that is very neat!
Knurled adjusters are cool, but never burning your wrist/finger/arm on an exhaust pipe again? Priceless.
 
Gonna give the windscreen a go.

i feel like putting the flyscreen in as a sandwich may help keep my cluster stationary though and keep it off the metal mounts on bottom. It’s adjustable a bit so I have some playroom.
B455F96C-F715-4422-A9F2-86FBB9F1B2A5.jpeg
E54D22D0-21EB-4DDF-9DB2-4DF799C75680.jpeg
5F1FFBDB-CD94-4F5B-A421-E23A608494CC.jpeg
 
45 miles on so far this week. Seems to go good after a few minutes, sputters a little when cold down low. Windscreen makes a huge difference at higher speeds.

could not for the life of me get it to stay running this morning lol I forgot to turn the gas on.

left the house at 12.3v even after a few minutes of trying to get it to turn over. Left the office at 11.9v with little trouble starting. 11.6 when I got home but I could see the volts climbing a bit when it was revving higher. I’m gonna double check my work testing the stator and regulator...

4FCD341B-C4D9-4775-A33D-91A2A55FDA3A.jpeg
 
interstate called me, they have the battery i was looking for a week ago in stock, lol

also they told me my charger probably killed my battery. 9a when 2-3a is required for these..... yeesh
 
Top